[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

Re: [Gzigzag-commits] gzigzag/Java ZZCell.java



> "Tuomas J. Lukka" wrote:
> > Update of /cvsroot/gzigzag/gzigzag/Java
> > In directory slayer.i.sourceforge.net:/tmp/cvs-serv29651
> > 
> > Modified Files:
> >         ZZCell.java
> > Log Message:
> > Make toString return the cell ID. Scream if this hurt you.
> 
> It doesn't *hurt*, but I've just realized I'm spending a lot of time
> writing debug messages which give both the cell contents and id, and
> debug messages are what I suppose this is intended for, so what about returning:
> 
> getText() + " (" + getID() + ")"
> 
> --? Because often when you debug, it's faster to identify a cell by its
> contents, but when it's e.g. empty or a clone, you need the id as well.
> This would be a lot of help for me -- is it o.k. with you if I change it
> that way?

I think I'd prefer

	getID()+"('"+getText()+"')"

since the ID is the main thing. Stringizing cells is only used for
debugging so we *might* even consider printing out connections on given
dimensions later on (but this would put a lot more verbage in the output).

	Tuomas