[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]
Set & Table hierarchy
- To: <tribble>
- Subject: Set & Table hierarchy
- From: Mark S. Miller <mark>
- Date: Sat, 18 Nov 89 13:56:59 PST
- Cc: <ravi>, <xtech>
- In-reply-to: <Eric>,59 PST <8911170525.AA11178@xanadu>
Date: Thu, 16 Nov 89 21:25:59 PST
From: tribble (Eric Dean Tribble)
ScruSet<Heaper> :: count() stepper()
isEmpty() hasMember(x) isSubsetOf(s)
mutable() immutable()
What do the "mutable" & "immutable" messages to a ScruSet mean? I can
think of several possibilities.
I think I made the suggestion for this. They should actually be
asImmutable and asMutable. asImmutable sent to a MuSet returns an
ImmuSet; sent to a MuTable returns an ImmuTable. I would like the
conversion messages between different state-change types to be the
same for Set and Table classes. It's easier to remember.
I sorry I'm quibbling about names like this, but here goes anyway.
Let's not make different capitalizations of the same sequence of
letters mean different things. The pun is costing us much more than
it's worth if "[mM]utable" and "[mM]uTable" are both in the code with
different meanings. For one thing, it makes speaking the code very
ambiguous. If you really want the same messages to both Sets and
Tables, how about "asMu()", "asImmu()", and "asScru()"?