[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

Re: [zzdev] Vob2D.render() parameters

> If we need more information in the future, it'll suffice to change
> RenderingInfo2D and the vob sets; we don't need to change _all_ vobs as well.

Vob.RenderInfo now contains some of these things. Some others are so
specific to the particular vob that they are passed as args.

> Connector2D: I've come to think that Decorator2D *would* be a better
> name for it. It should be called rather like the vobs:
>     abstract public void renderDecor(Graphics g, Vob2D v, RenderingInfo i);
> The reason to call it Decorator is that it never draws a whole
> connection-- it only draws the half of a connection attached to a
> specific vob. Now, that means the class can be used just as well to do
> other kinds of decorations of vobs-- e.g., a "lock" symbol next to a
> cell vob of a cell that can't be edited, or a "link" symbol next to a
> cursor cell. Decorator2D would be an easy way to handle these
> efficiently, too-- and with the right behaviour: if they're interpolated
> at all, they should be interpolated together with the vob.

People on zzdev might be interested in reading our long discussion about
this matter on #gzigzag at ircnet, archived at