[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

Re: [zzdev] Re: [zzdev] Re: [zzdev] Errors and exceptions

On 20010415T014047+0300, Tuomas Lukka wrote:
> > Absolutely agreed. (Do we really need to prefix that it with 'ZZ'?
> > 'ClangException' seems to be unique enough. 'InfiniteLoopException'
> > should IMO not be prefixed either, because the loop detector is not
> > connected to ZZ except that the code was written on this project.)
> And the code is part of ZZ. I do prefer having the exceptions clearly
> marked as being in our code (as opposed to JVM or JDK).

The package name is sufficient for this.  If you want to emphasize,
use the full-qualified name.

There should be no ZZ prefixes.  They're evil.  They are useful only when
there is no better namespace mechanism, and this is not true for Java.

%%% Antti-Juhani Kaijanaho % gaia@xxxxxx % http://www.iki.fi/gaia/ %%%