[Date Prev][Date Next][Thread Prev][Thread Next][Author Index][Date Index][Thread Index]

Re: just plain trouble again

On Mon, Oct 25, 1999 at 12:55:21AM +0200, 17.Z>XRT_tWz.430.57  wrote:
> after doing a system upgrade (debian 2.1 => 2.2) i get this behaviour:
> $ ./zigzag
> Segmentation fault
> $ ./zigzag
> Use of uninitialized value at Zigzag.pm line 956.
> Sorry, this data file predates Zigzag v0.44.1.1.
> $
> so a segfault on creating the initial dataset, and that "predates ..."
> message afterwards.
> also a segfault when i try to open an existing dataset ..
> hints? ;)

I would guess that your Berkeley DB got upgraded and the database file
format changed.  Check the DB documentation to see if there's a way
to convert.  Otherwise you may have to downgrade DB, zzdump the data,
upgrade again, and zzundump.

Hope that helps,
		*** Xanni ***
mailto:xanni@xxxxxxxxxx                         Andrew Pam
http://www.xanadu.com.au/                       Chief Scientist, Xanadu
http://www.glasswings.com.au/                   Technology Manager, Glass Wings
http://www.sericyb.com.au/sc/                   Manager, Serious Cybernetics
P.O. Box 26, East Melbourne VIC 8002 Australia  Phone +61 3 9419-2989